StarShip SHA-2 Security Update

UPS and FedEx security updates are impacting the StarShip Server Minimum System Requirements! OnTrac, Estes and Old Dominion have also made security changes.
The updated requirements reflect the move from SHA-1 encryption to the new and more secure industry standards of SHA-256 (SHA-2) encryption and TLS protocol. Simply stated, older operating systems will no longer be able to communicate with any carriers once they finalize their move to SHA-2 and TLS 1.2..

Does this affect me?
Specifically, if your StarShip Server is running on:

  • Windows Server 2003
  • Windows XP
  • Windows Server 2008
  • Windows Vista

you should plan to upgrade to one of the following compatible operating systems:

  • Windows Server 2012R2
  • Windows Server 2012
  • Small Business Server 2011
  • Windows Server 2008R2 SP1
  • Windows 10
  • Windows 8
  • Windows 7 SP1

When do I need to do this?

  • NOW – Start planning your Server OS migration!
  • By January 30, 2016 – You will need to EITHER upgrade your Server OS -or- install this hotfix from Microsoft to your StarShip Server machine. A reboot is required after the hotfix is complete.
  • NOW – StarShip Server must be moved to a supported OS in order to install version 17.2.
  • PRIOR TO December 31, 2017 – Users must be running StarShip 16.2 or higher in order to continue shipping with UPS. UPS Security Updates

What about my client machines?
Starting with version 16.2, the StarShip Client will need to be installed on workstations with one of the following operating systems:

  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7 SP1
  • Windows Vista SP2

But don’t wait too long…
StarShip v16.2 and all subsequent versions now REQUIRE the Server be installed on Windows 7 or Windows Server 2008 R2 or higher.

Can I get help?
Yes! We offer support services that can help you migrate your StarShip Server.
Contact our Sales Team for a quote specific to your implementation.

If your system already supports SHA-2 security standards, then no action is necessary; but if your system only supports SHA-1 based certificate verification and/or an SSLv3 protocol, you will experience connection issues if you fail to update both. Customers will need a plan to support SHA-2 and TLS prior to December 30, 2017.